Uso de metricas con mas de una puerta de enlace en Windows

Estimados lectores, en este nuevo artículo vamos a ver un ejemplo de uso de metricas con mas de una puerta de enlace en Windows y es que a veces nos pueden ocurrir cosas como estar conectados a una red Gigabit, con el correspondiente cable RJ45, de la cual recibimos sus datos por DHCP entre los que se encuentra la puerta de enlace y que tengamos la mala suerte de no tener Internet justo cuando más falta nos hace y sin podernos desconectar (por ejemplo quitar el cable y conectar otro de una red distinta). Continuar leyendo “Uso de metricas con mas de una puerta de enlace en Windows”

Backup de la configuracion de un Switch HP ProCurve

Estimados lectores, en esta ocasión vamos a ver cómo realizar un backup de la configuracion de un Switch HP ProCurve usando la herramienta TFTPD32 como hemos hecho en otras ocasiones para Actualizar el firmware de este tipo de conmutadores. No hace falta decir que deberíamos realizar backups de la configuración de nuestra electrónica de red de forma periódica no solo en las memorias flash de los commutadores sino también hacia nuestro servidor de archivos que, a su vez, debería tener su política de respaldo. Continuar leyendo “Backup de la configuracion de un Switch HP ProCurve”

Descubrir puertos Ethernet VMware ESXi en HP ProCurve

Estimados lectores, en este nuevo artículo veremos cómo descubrir puertos Ethernet VMware ESXi en HP ProCurve. Partimos de una infraestructura virtual VMware vSphere con una configuración de red basada en Standard vSwitchs cuyos Uplinks están conectados a una electrónica de HP ProCurve. Como sabemos los vSwitchs Standard soportan CDP (Cisco Discovery Protocol) de forma predeterminada así que si tuviéramos este tipo de electrónica podríamos consultar la información de los puertos físicos desde VMware. Continuar leyendo “Descubrir puertos Ethernet VMware ESXi en HP ProCurve”

Actualizar el Firmware de un Switch ProCurve de HP

Estimados lectores, ¡hemos cumplido el primer año! Vamos camino de las 120.000 visitas y quiero aprovechar para daros las gracias a todos los que pasáis por aquí a leer estos artículos.

Hoy vamos a ver cómo actualizar el Firmware de un Switch ProCurve de HP, concretamente veremos el procedimiento para un chasis E5406zl con 5 tarjetas (módulos) de 24 puertos PoE que he instalado recientemente para un proyecto de networking. Para este procedimiento necesitaremos un servidor TFTP como por ejemplo TFTPD32 que es el que suelo usar habitualmente. Continuar leyendo “Actualizar el Firmware de un Switch ProCurve de HP”

Administrar Distributed vSwitches en VMware vSphere 5.5

Estimados lectores,

En este nuevo artículo vamos a ver cómo administrar Distributed vSwitches en VMware vSphere 5.5 para infraestructuras virtuales con Licencia Enterprise Plus. Estos switchs distribuidos se administran de forma centralizada desde vCenter ayudándonos a simplificar la configuración de red de nuestra infraestructura virtual. A diferencia de los Standard vSwitches los cuales generamos de forma manual en cada uno de los Hosts ESXi, con Distributed vSwitches creamos los Port Groups para VLANs de máquinas virtuales o bien para vMkernels de forma centralizada para todos los servidores ESXi del Datacenter. De esta forma todos los Hosts tienen exactamente la misma configuración de red evitando, por ejemplo, errores típicos como el ID de VLAN o el nombre de la Virtual Machine Network que puede configurarse de forma incorrecta cuando configuramos “a mano” cada ESXi de forma individual. Continuar leyendo “Administrar Distributed vSwitches en VMware vSphere 5.5”

Crear una nueva VLAN sobre un virtual interface de NetApp

Podemos crear una nueva VLAN sobre un virtual interface de NetApp que contiene VLANs de forma no disruptiva siguiendo este procedimiento:

1) Accedemos por SSH/Telnet al contexto de Data Ontap de la controladora NetApp Continuar leyendo “Crear una nueva VLAN sobre un virtual interface de NetApp”

Agregación de puertos Ethernet de una NetApp: ejemplo con electrónica Cisco

Esquema de conexionado con switchs independientes (no stacking) para la agregación de puertos Ethernet de una NetApp:

Agregación de puertos Ethernet de una NetApp: ejemplo con electrónica Cisco

Configuración del fichero RC:

NetApp> rdfile /etc/rc
 #Ejemplo de configuración en LACP con dos VIFs 2+2 (2Gbps) y un tercero activo pasivo
 hostname NetApp
 ifgrp create lacp ig0 -b ip e0a e0b
 ifgrp create lacp ig1 -b ip e0c e0d
 ifgrp create single vif1 ig0 ig1
 ifconfig vif1 `hostname`-vif1 mediatype auto netmask 255.255.255.0 mtusize 1500 partner vif1
 ifconfig e0a flowcontrol send
 ifconfig e0b flowcontrol send
 ifconfig e0c flowcontrol send
 ifconfig e0d flowcontrol send
 ifconfig vif1 nfo
 route add default 192.168.0.1 1
 routed on
 options dns.domainname davidsole.es
 options dns.enable on
 options nis.enable off
 savecore

Configuración del fichero HOSTS:

NetApp> rdfile /etc/hosts
 #Ejemplo de configuración del Fichero de Hosts
 127.0.0.1     localhost    localhost-stack
 127.0.10.1    localhost-10 localhost-bsd
 127.0.20.1    localhost-20 localhost-sk
 192.168.0.10  NetApp       NetApp-vif1
 # 0.0.0.0     NetApp-e0M
 # 0.0.0.0     NetApp-e0P
 # 0.0.0.0     NetApp-e1a
 # 0.0.0.0     NetApp-e1b
 192.168.0.100 mailhost

Configuración de los puertos de ig0 en Switch01:

port-channel load-balance src-dst-ip
interface Port-channel1
 description NetApp ig0 LACP e0a-e0b
 switchport
 switchport access vlan 10
 switchport mode access
 flowcontrol receive on
 no cdp enable
 spanning-tree guard loop
 !
 interface GigabitEthernet1/0/1
 description NetApp e0a
 switchport access vlan 10
 switchport mode access
 flowcontrol receive on
 no cdp enable
 spanning-tree guard loop
 channel-group 1 mode active
 !
 interface GigabitEthernet1/0/2
 description NetApp e0b
 switchport access vlan 10
 switchport mode access
 flowcontrol receive on
 no cdp enable
 spanning-tree guard loop
 channel-group 1 mode active
 !

Configuración de los puertos de ig1 en Switch02:

port-channel load-balance src-dst-ip
interface Port-channel1
 description NetApp ig1 LACP e0c-e0d
 switchport
 switchport access vlan 10
 switchport mode access
 flowcontrol receive on
 no cdp enable
 spanning-tree guard loop
 !
 interface GigabitEthernet1/0/1
 description NetApp e0c
 switchport access vlan 10
 switchport mode access
 flowcontrol receive on
 no cdp enable
 spanning-tree guard loop
 channel-group 1 mode active
 !
 interface GigabitEthernet1/0/2
 description NetApp e0d
 switchport access vlan 10
 switchport mode access
 flowcontrol receive on
 no cdp enable
 spanning-tree guard loop
 channel-group 1 mode active
 !


Licencia de Creative Commons

This Post by David Solé Pérez is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License

Pagina Principal